Rewards engine stoppage during deployment
Incident Report for Hummingbot Miner
Resolved
This incident has been resolved.
Posted May 08, 2020 - 21:02 PDT
Update
We have reverted the patch and restored the Rewards Engine.
Posted May 08, 2020 - 09:42 PDT
Update
We're still working on this issue. We rolled out a fix but it exhibited unusual behavior during monitoring so we are currently investigating.
Posted May 07, 2020 - 23:02 PDT
Update
We are continuing to work on a fix for this issue.
Posted May 07, 2020 - 18:31 PDT
Identified
During a scheduled deployment this afternoon, we encountered an issue that caused the Rewards Engine component to exceed the Binance rate limit. We have identified the fix and are currently waiting for the rate limit to resolve before deploying the Rewards Engine.

Our Binance data fetcher is unaffected and running bots should keep earning rewards during this outage.
Posted May 07, 2020 - 18:31 PDT
This incident affected: Data fetchers (Binance Data Fetcher), APIs (Miner API), and Reward Aggregators (Binance Rewards Engine).