Critical errors in Hummingbot Miner and connections to Binance API
Incident Report for Hummingbot Miner
Resolved
The Binance data fetcher experienced a brief outage overnight, while the Miner app was out for approximately 10 hours. This issue was related to the deprecation by Binance of a legacy endpoint in their API. Our Binance data fetchers and Hummingbot clients were affected by this issue, as well as downstream components like Rewards Engine and Miner app.

Binance subsequently reverted the deprecation, and we have deployed a patch so the Miner app is working again. We are fixing both our data fetchers and the Hummingbot open source client to remove dependency on this legacy endpoint.
Posted May 09, 2020 - 09:19 PDT
Investigating
Currently, the APIs that power the Hummingbot Miner app is down. In addition, users have reported bugs with the form "Could not fetch trading rules..."
Posted May 09, 2020 - 02:09 PDT
This incident affected: Data fetchers (Binance Data Fetcher), APIs (Miner API), and Reward Aggregators (Binance Rewards Engine).